环境:
- VMware® Workstation 17 Pro 17.6.4 build-24832109
- debian-13.7.0-amd64-DVD-1.iso
一、下载 debian
可通过百度网盘下载:
链接: https://pan.baidu.com/s/1_1-Df532FHCbeficiDtt2Q?pwd=takh 提取码: takh
也可以从官网下载:https://www.debian.org/distrib/index.html
下载完成后,文件大小约为 3.7G,如下图所示:
二、新建虚拟机
至此,新的虚拟机就创建完成了。
三、 安装
首先,设置虚拟机的光驱
点击这里继续后,就自动重启虚拟机了。
启动的时候,有个选择项(我没注意,它自己跳过去了,不用理它)。
现在,我们可以先关机,将光驱设置为空再重启:
下面的界面可以按回车也可以不按:
看到下图就启动成功了:
四、基本配置
现在让我们用root登录:
4.1 先查看 ip,远程登录
拿到 ip 后,我们就可以用ssh工具远程登录了,这里我用finalshell:
4.2 处理 apt 源
先切换到管理员用户
然后先尝试执行apt update报错:
这个错误是因为安装用的 dvd 导致系统把这个dvd文件当做源了。
现在,我们修改配置文件,将源改为阿里的:
cat>/etc/apt/sources.list<<'EOF' deb https://mirrors.aliyun.com/debian/ trixie main contrib non-free non-free-firmware deb https://mirrors.aliyun.com/debian/ trixie-updates main contrib non-free non-free-firmware deb https://mirrors.aliyun.com/debian/ trixie-backports main contrib non-free non-free-firmware deb https://mirrors.aliyun.com/debian-security/ trixie-security main contrib non-free non-free-firmware EOF然后再执行apt update
4.3 安装 vim
默认安装只有vi没有vim,我们安装它:
aptinstallvim-y4.4 安装 sudo
默认安装只有su命令,没有sudo, 我们安装它:
aptinstallsudo-y4.4 设置允许root账户远程登录
默认,root账户是不能远程登录的,我们需要修改配置文件/etc/ssh/sshd_config:
注意: 生产环境慎重
做法就是将 /etc/ssh/sshd_config 这个文件的 PermitRootLogin 这一行,将其修改为 yes,如:
# 查找并修改(如果行首有#,需要去掉注释) PermitRootLogin yes为了方便,我们可以使用 sed 命令操作:
sudosed-i's/^#\?PermitRootLogin.*/PermitRootLogin yes/'/etc/ssh/sshd_config如果命令没有输出,说明语法正确。然后重启 SSH 服务使配置生效:
然后执行:
sudosystemctl daemon-reloadsudosystemctl restartssh然后,就可以退出使用 root 账户登录了。
4.5 检查时区配置
timedatactl
默认就是东八区,就这样挺好。